Unable to Load Prosites and Backups

Incident Report for GoDaddy

Resolved

This issue has been resolved.
Posted Apr 11, 2025 - 22:45 UTC

Investigating

We are investigating an issue that was preventing customers from accessing their GoDaddy Prosites and Backups
Posted Apr 11, 2025 - 22:40 UTC
This incident affected: GoDaddy.com (The Hub by GoDaddy Pro).