Domain Name Registration Outage
Incident Report for
GoDaddy
Resolved
This issue has been resolved.
Posted
May
29
,
2025
-
23:46
UTC
Investigating
We're investigating domain related issues that are impacting, but not limited to, Domain Registrations, Renewals and Transfers.
Posted
May
29
,
2025
-
22:39
UTC
This incident affected: Domain Services (Domain Registration).
×
Subscribe to Incident
Subscribe to updates for
Domain Name Registration Outage
via . You'll receive .