Airo Builder & Managed Wordpress Degraded

Incident Report for GoDaddy

Resolved

This issue has been resolved.
Posted May 22, 2026 - 16:41 UTC

Update

We are continuing to investigate this issue.
Posted May 22, 2026 - 16:22 UTC

Investigating

We are currently investigating an issue affecting new Airo and Managed WordPress sites that are not completing setup.
Posted May 22, 2026 - 16:12 UTC
This incident affected: Websites and Stores (GoDaddy Airo).