Website Security Dashboard Degraded

Incident Report for GoDaddy

Resolved

This incident has been resolved.
Posted Mar 31, 2026 - 09:39 UTC

Investigating

We are currently investigating an issue causing latency and timeouts related to Website Security Dashboard.
Posted Mar 31, 2026 - 09:37 UTC
This incident affected: Web Security (Website Security).