Office 365 Dashboard Degraded

Incident Report for GoDaddy

Resolved

This issue has been resolved.
Posted Apr 21, 2026 - 23:31 UTC

Investigating

We are investigating an issue causing an error on Office 365 Dashboard. Thank you for your patience.
Posted Apr 21, 2026 - 22:03 UTC
This incident affected: Email & Productivity (Professional Email with Microsoft 365).