Professional Email Degraded Accessibility

Incident Report for GoDaddy

Resolved

This issue has been resolved.
Posted Jul 17, 2025 - 19:55 UTC

Update

We are currently investigating an issue impacting the ability to login to email applications for the Professional Email service globally. However, some customers may be able to access their inboxes by directly visiting email.secureserver.net and logging in then accessing their Productivity Panel.
Posted Jul 17, 2025 - 16:39 UTC

Update

We are currently investigating an issue impacting the ability to login to webmail and email applications for the Professional Email service globally. However, some customers may be able to access their inboxes by directing visiting email.secureserver.net and logging in then accessing their Productivity Panel.
Posted Jul 17, 2025 - 16:29 UTC

Investigating

We are currently investigating an issue impacting the ability to login to webmail and email applications for the Professional Email service in European Region.
Posted Jul 17, 2025 - 14:44 UTC
This incident affected: Email & Productivity (Professional Email).