Microsoft Office 365 Proofpoint Degraded Accessibi

Incident Report for GoDaddy

Resolved

This issue has been resolved.
Posted Jun 11, 2025 - 20:49 UTC

Update

We are continuing to investigate this issue.
Posted Jun 11, 2025 - 19:04 UTC

Investigating

We are currently investigating an issue causing delays sending and receiving email for a subset of customer using M365 email, and accessing Advanced Email Security
Posted Jun 11, 2025 - 18:40 UTC
This incident affected: Email & Productivity (Professional Email with Microsoft 365).