Airo Builder Dashboard And Websites Degraded
Incident Report for
GoDaddy
Resolved
This issue has been resolved.
Posted
Aug
06
,
2026
-
07:58
UTC
Monitoring
We have implemented a fix and most Airo AI Builder dashboards and websites hosted on the platform should be accessible.
Posted
Aug
06
,
2026
-
06:34
UTC
Investigating
We are currently investigating an issue affecting the availability of customer websites and the Airo Builder dashboard.
Posted
Aug
06
,
2026
-
04:19
UTC
This incident affected: Airo AI App Builder™ (Site Creation, UI).
×
Subscribe to Incident
Subscribe to updates for
Airo Builder Dashboard And Websites Degraded
via . You'll receive .