GoDaddy My Products Page Degraded

Incident Report for GoDaddy

Resolved

This issue has been resolved.
Posted Nov 01, 2025 - 00:00 UTC

Update

We are continuing to investigate this issue.
Posted Oct 31, 2025 - 23:26 UTC

Investigating

We are currently investigating and issue impacting the ability to edit settings and setup Managed WordPress and Web Hosting products.
Posted Oct 31, 2025 - 23:19 UTC
This incident affected: GoDaddy.com (GoDaddy My Products Pages).