Managed Wordpress Degraded
Incident Report for
GoDaddy
Resolved
This issue has been resolved.
Posted
Jul
11
,
2026
-
04:01
UTC
Investigating
We are aware of issues causing some servers to be unavailable. We are working to resolve this.
Posted
Jul
11
,
2026
-
02:14
UTC
This incident affected: Managed WordPress Hosting (Managed WooCommerce Stores).
×
Subscribe to Incident
Subscribe to updates for
Managed Wordpress Degraded
via . You'll receive .