Domain Purchases Degraded
Incident Report for GoDaddy
Resolved
This issue has been resolved.
Posted Oct 17, 2024 - 22:18 UTC
Investigating
We are currently investigating an issue impacting the ability to purchase domains on Afternic.
Posted Oct 17, 2024 - 21:58 UTC
This incident affected: Domain Services (Afternic).