Website Builder Degraded
Incident Report for
GoDaddy
Resolved
This issue has been resolved.
Posted
Nov
12
,
2024
-
12:27
UTC
Investigating
We are currently investigating an issue impacting the management of websites created with Website Builder for the European Region.
Posted
Nov
12
,
2024
-
11:16
UTC
This incident affected: Websites and Stores (Website Builder).
×
Subscribe to Incident
Subscribe to updates for
Website Builder Degraded
via . You'll receive .