Login Pages Degraded

Incident Report for GoDaddy

Resolved

This issue has been resolved.
Posted Apr 23, 2025 - 12:11 UTC

Investigating

We are currently investigating an issue impacting the ability to login to our website.
Posted Apr 23, 2025 - 11:11 UTC
This incident affected: GoDaddy.com (GoDaddy Login Pages).