Delayed Support Services
Incident Report for
GoDaddy
Resolved
This issue has been resolved.
Posted
Nov
26
,
2024
-
20:14
UTC
Investigating
We are currently investigating an issue causing support services to be delayed.
Posted
Nov
26
,
2024
-
20:00
UTC
This incident affected: GoDaddy Support (Messaging Support Services, Voice Support Services).
×
Subscribe to Incident
Subscribe to updates for
Delayed Support Services
via . You'll receive .