Web Hosting Dashboard Degraded

Incident Report for GoDaddy

Resolved

This issue has been resolved.
Posted Feb 26, 2026 - 16:13 UTC

Investigating

We are currently investigating an issue causing Web Hosting administrative features to be unavailable and latent.
Posted Feb 26, 2026 - 16:00 UTC
This incident affected: Web Hosting (Web Hosting).