GoDaddy Payments Declined Transactions
Incident Report for GoDaddy
Resolved
This issue has been resolved.
Posted Apr 24, 2024 - 21:05 UTC
Investigating
We are currently investigating an issue with declined transactions using GoDaddy Payments.
Posted Apr 24, 2024 - 20:33 UTC
This incident affected: GoDaddy.com (GoDaddy Shopping Cart) and Websites and Stores (GoDaddy Payments).