Order & Product Fulfillment Degraded

Incident Report for GoDaddy

Resolved

This issue has been resolved.
Posted Oct 15, 2025 - 09:35 UTC

Investigating

We are currently investigating an issue causing delay in processing new orders of products in the Asian region.
Posted Oct 15, 2025 - 08:45 UTC
This incident affected: GoDaddy.com (Order & Product Fulfillment).