Web Hosting Maintenance
Incident Report for
GoDaddy
Resolved
This issue has been resolved.
Posted
Jul
10
,
2026
-
19:06
UTC
Monitoring
We are currently running maintenance across our Web Hosting platform which may cause websites and the hosting dashboard to experience brief downtime.
Posted
Jul
09
,
2026
-
22:45
UTC
This incident affected: Web Hosting (Web Hosting, Web Hosting Plus).
×
Subscribe to Incident
Subscribe to updates for
Web Hosting Maintenance
via . You'll receive .