Managed Wordpress Degredation

Incident Report for GoDaddy

Resolved

This issue has been resolved.
Posted Jan 13, 2026 - 19:36 UTC

Investigating

We are currently investigating connectivity issues impacting the myftpupload.com domain for Managed WordPress services.
Posted Jan 13, 2026 - 19:32 UTC
This incident affected: WordPress Hosting (Managed WordPress Hosting 1.0).