Web Hosting, Wordpress, and Web Security Dashboards Degraded

Incident Report for GoDaddy

Resolved

This issue has been resolved.
Posted Aug 01, 2025 - 01:04 UTC

Investigating

We are currently investigating an issue causing some Wordpress, Web Hosting, and Web Security administrative features to be unavailable and latent.
Posted Aug 01, 2025 - 00:42 UTC
This incident affected: Web Hosting (Web Hosting) and Web Security (Website Security).