Support Services Degraded

Incident Report for GoDaddy

Resolved

This issue has been resolved.
Posted Aug 10, 2025 - 19:19 UTC

Investigating

We are currently investigating an issue causing both of our chat and phone customer service support to be unavailable.
Posted Aug 10, 2025 - 19:01 UTC
This incident affected: GoDaddy Support (Voice Support Services).