Order Fulfillment Degraded

Incident Report for GoDaddy

Resolved

This issue has been resolved.
Posted Apr 08, 2026 - 15:02 UTC

Investigating

We are currently investigating issues causing new orders to not appear in customer accounts.
Posted Apr 08, 2026 - 14:48 UTC
This incident affected: GoDaddy.com (Order & Product Fulfillment).