Online Store Degraded Websites

Incident Report for GoDaddy

Resolved

This issue has been resolved.
Posted Jun 04, 2026 - 04:25 UTC

Investigating

We are currently investigating issues causing websites hosted on our Online Store Builder platform to be intermittently unavailable.
Posted Jun 04, 2026 - 03:19 UTC
This incident affected: Websites and Stores (Online Store Builder).