Support Unable to Access Customer Accounts
Incident Report for
GoDaddy
Resolved
This issue has been resolved.
Posted
Aug
05
,
2025
-
15:02
UTC
Investigating
We are investigating an issue that is preventing our support channels from accessing customer accounts globally.
Posted
Aug
05
,
2025
-
15:01
UTC
This incident affected: GoDaddy Support (Messaging Support Services, Voice Support Services).
×
Subscribe to Incident
Subscribe to updates for
Support Unable to Access Customer Accounts
via . You'll receive .