Account Settings Degraded
Incident Report for
GoDaddy
Resolved
This issue has been resolved.
Posted
Sep
26
,
2024
-
17:58
UTC
Investigating
We are investigating an issue causing some Account Settings pages to not load properly. We are working to restore service as soon as possible.
Posted
Sep
26
,
2024
-
17:33
UTC
This incident affected: GoDaddy.com (GoDaddy My Products Pages).
×
Subscribe to Incident
Subscribe to updates for
Account Settings Degraded
via . You'll receive .