Managed WordPress Hosting 1.0 Degraded Dashboard

Incident Report for GoDaddy

Resolved

This issue has been resolved.
Posted Aug 28, 2025 - 12:09 UTC

Investigating

We are currently investigating an issue causing the WordPress Hosting administrative features to be unavailable and latent.
Posted Aug 28, 2025 - 12:07 UTC
This incident affected: WordPress Hosting (Managed WordPress Hosting 1.0).