Managed Wordpress Services Degraded
Incident Report for
GoDaddy
Resolved
This incident has been resolved.
Posted
Apr
09
,
2025
-
03:13
UTC
Investigating
We're currently investigating connectivity stability issues from european service providers to our Managed Wordpress environment
Posted
Apr
08
,
2025
-
23:18
UTC
This incident affected: WordPress Hosting (Managed WordPress Hosting 1.0).
×
Subscribe to Incident
Subscribe to updates for
Managed Wordpress Services Degraded
via . You'll receive .