Login Degraded

Incident Report for GoDaddy

Resolved

This issue has been resolved.
Posted Jun 16, 2026 - 16:51 UTC

Investigating

We are currently investigating an issue affecting customers' ability to log in to their accounts. Some or all login attempts may fail or result in an error. Our team has been engaged and is actively working to identify the root cause.
Posted Jun 16, 2026 - 16:47 UTC
This incident affected: GoDaddy.com (GoDaddy Login Pages).