Domain Renewal Degraded

Incident Report for GoDaddy

Resolved

This issue has been resolved.
Posted Apr 10, 2025 - 08:40 UTC

Investigating

We are currently investigating an issue causing domain registration and domain renewal events to be delayed.
Posted Apr 10, 2025 - 07:23 UTC
This incident affected: Domain Services (Domain Registration).