Hosting Page Degraded

Incident Report for GoDaddy

Resolved

This issue has been resolved.
Posted Mar 26, 2026 - 15:33 UTC

Investigating

We are currently investigating an issue affecting customers' ability to manage hosting plans within their accounts.
Posted Mar 26, 2026 - 15:30 UTC
This incident affected: GoDaddy.com (GoDaddy My Products Pages).