GoDaddy Cart
Incident Report for GoDaddy
Resolved
This issue has been resolved.
Posted Sep 30, 2024 - 18:50 UTC
Investigating
We are currently investigating an issue causing payment methods to not load in the cart. Our engineers are working to resolve this as soon as possible.
Posted Sep 30, 2024 - 17:53 UTC
This incident affected: GoDaddy.com (GoDaddy Shopping Cart).