Microsoft 365 Web Suite Degraded

Incident Report for GoDaddy

Resolved

This issue has been resolved.
Posted Sep 08, 2026 - 17:56 UTC

Investigating

We are currently aware of customers being unable to access the Microsoft 365 Web Suite. We are working with teams to resolve the issue.
Posted Sep 08, 2026 - 15:59 UTC
This incident affected: Email & Productivity (Professional Email with Microsoft 365).