DNS Resolution Degraded

Incident Report for GoDaddy

Resolved

This issue has been resolved.
Posted Dec 12, 2025 - 22:10 UTC

Investigating

We are currently investigating an issue causing site availability issues. We are working to resolve this as soon as possible.
Posted Dec 12, 2025 - 21:42 UTC
This incident affected: Websites and Stores (Website Builder), WordPress Hosting (Managed WordPress Hosting 2.0), and Domain Services (DNS).