Domain Search Degraded

Incident Report for GoDaddy

Resolved

This issue has been resolved.
Posted Nov 07, 2025 - 19:49 UTC

Investigating

We are currently investigating an issue intermittently impacting the ability of customers to search for domains.
Posted Nov 07, 2025 - 16:21 UTC
This incident affected: Domain Services (Domain Name Search).