Payments Hub Degraded

Incident Report for GoDaddy

Resolved

This issue has been resolved.
Posted May 05, 2026 - 18:41 UTC

Investigating

We are aware of an issue causing "access restricted" messages in the GoDaddy Commerce app. Customers experiencing this issue can log out and log back in to resolve it. We apologize for the inconvenience and appreciate your patience.
Posted May 05, 2026 - 16:33 UTC
This incident affected: GoDaddy Payments (Payments Hub).