Web Hosting Websites Degraded

Incident Report for GoDaddy

Resolved

This issue has been resolved.
Posted Apr 15, 2026 - 22:53 UTC

Investigating

We are currently investigating an issue causing websites on the cPanel Web Hosting platform to be unavailable or latent in all regions.
Posted Apr 15, 2026 - 15:06 UTC
This incident affected: Web Hosting (Web Hosting).