Windows Hosting Sites and Managed WordPress Sites
Incident Report for
GoDaddy
Resolved
This issue has been resolved.
Posted
Jun
18
,
2025
-
19:38
UTC
Identified
The issue that impacted Windows Web Hosting has been resolved. We are continuing to investigate the issue impacting Managed WordPress 1.0.
Posted
Jun
18
,
2025
-
19:36
UTC
Investigating
We are currently investigating multiple issues impacting Windows Web Hosting and Managed WordPress 1.0 in the North American region.
Posted
Jun
18
,
2025
-
18:51
UTC
This incident affected: WordPress Hosting (Managed WordPress Hosting 1.0).
×
Subscribe to Incident
Subscribe to updates for
Windows Hosting Sites and Managed WordPress Sites
via . You'll receive .