We are currently investigating an issue affecting websites hosted on our Website Builder platform, which may cause them to display a "Not Secure" message. While our engineering team works to fix these issues globally, in some cases republishing your site may resolve impact. To republish the site please follow https://www.godaddy.com/help/publish-my-websites-marketing-site-20115. We apologize for any inconvenience and appreciate your patience as we work to resolve this matter.
Posted Apr 14, 2026 - 01:05 UTC
Investigating
We are currently investigating an issue causing websites hosted on our Website Builder platform to display a "Not Secure" message. Thank you for your patience.
Posted Apr 13, 2026 - 19:30 UTC
This incident affects: Websites and Stores (Website Builder).