Managed WordPress Hosting Sites Degraded

Incident Report for GoDaddy

Resolved

This incident has been resolved.
Posted Apr 16, 2026 - 12:59 UTC

Investigating

We are currently investigating an issue causing delays in creation of new websites hosted on the Managed WordPress Hosting platform.
Posted Apr 16, 2026 - 12:59 UTC
This incident affected: Managed WordPress Hosting (Site Creation).