Order/Product Fulfillment Degraded

Incident Report for GoDaddy

Resolved

This issue has been resolved.
Posted May 08, 2025 - 17:49 UTC

Investigating

We are currently investigating an issue causing delays in Order/Product processing. This may cause new orders to not appear in your account while we work to address this.
Posted May 08, 2025 - 15:13 UTC
This incident affected: GoDaddy.com (Order & Product Fulfillment).