GoDaddy Shopping Cart Degraded
Incident Report for
GoDaddy
Resolved
This issue has been resolved.
Posted
Nov
26
,
2024
-
16:38
UTC
Investigating
We are currently investigating issues causing latency when adding products to Cart.
Posted
Nov
26
,
2024
-
15:10
UTC
This incident affected: GoDaddy.com (GoDaddy Shopping Cart).
×
Subscribe to Incident
Subscribe to updates for
GoDaddy Shopping Cart Degraded
via . You'll receive .