Web Hosting Websites Degraded

Incident Report for GoDaddy

Resolved

This issue has been resolved.
Posted Jul 29, 2025 - 13:57 UTC

Update

We are continuing to investigate this issue.
Posted Jul 29, 2025 - 13:16 UTC

Investigating

We are currently investigating an issue causing websites on our Web Hosting and Web Hosting Plus platforms to be unavailable in the European Region.
Posted Jul 29, 2025 - 11:22 UTC
This incident affected: Web Hosting (Web Hosting).