Login Page Unavailable

Incident Report for GoDaddy

Resolved

This issue has been resolved.
Posted Apr 17, 2025 - 04:59 UTC

Investigating

We are currently investigating an issue preventing customers from signing in to their account using their email address.
Posted Apr 17, 2025 - 04:45 UTC
This incident affected: GoDaddy.com (GoDaddy Login Pages).