GoDaddy Afternic Degraded
Incident Report for
GoDaddy
Resolved
This issue has been resolved.
Posted
Jan
14
,
2026
-
13:43
UTC
Investigating
We are currently investigating an issue causing "For Sale" Lander URLs to be degraded.
Posted
Jan
14
,
2026
-
10:37
UTC
This incident affected: Domain Services (Afternic).
×
Subscribe to Incident
Subscribe to updates for
GoDaddy Afternic Degraded
via . You'll receive .