Afternic Domain Purchase Degraded

Incident Report for GoDaddy

Resolved

This issue has been resolved.
Posted Jul 16, 2025 - 16:03 UTC

Investigating

We are currently investigating an issue impacting the ability to purchase domains on the Afternic platform.
Posted Jul 16, 2025 - 15:41 UTC
This incident affected: Domain Services (Afternic).