My Products Page Degraded

Incident Report for GoDaddy

Resolved

This issue has been resolved.
Posted Jun 27, 2025 - 10:54 UTC

Investigating

We are currently investigating an issue impacting access to cPanel hosting accounts from My Products Page.
Posted Jun 27, 2025 - 10:26 UTC
This incident affected: GoDaddy.com (GoDaddy My Products Pages).