Airo Builder Degraded Dashboard

Incident Report for GoDaddy

Resolved

This issue has been resolved.
Posted Apr 09, 2026 - 11:03 UTC

Investigating

We are currently investigating an issue causing the Airo AI App Builder administrative functionality to be unavailable and latent.
Posted Apr 09, 2026 - 09:06 UTC
This incident affected: Airo AI App Builder™ (LLM).