GoDaddy Payments Degraded

Incident Report for GoDaddy

Resolved

This issue has been resolved.
Posted Sep 17, 2025 - 02:11 UTC

Investigating

We are currently investigating issue affecting both GoDaddy Payments and Commerce Home. Thank you for your patience.
Posted Sep 17, 2025 - 02:01 UTC
This incident affected: GoDaddy Payments (Payments Hub).