Multiple Services Unavailable
Incident Report for GoDaddy
Resolved
This issue has been resolved.
Posted Nov 25, 2024 - 23:51 UTC
Investigating
We are currently aware of an issue affecting multiple Microsoft M365 services globally. Microsoft is aware of this issue and is actively working on a solution.
Posted Nov 25, 2024 - 17:23 UTC
This incident affected: Email & Productivity (Professional Email with Microsoft 365).