Chat Support Degraded
Incident Report for
GoDaddy
Resolved
This issue has been resolved.
Posted
Jul
27
,
2026
-
22:45
UTC
Investigating
Our chat support is temporarily unavailable. Our team is aware of the issue and is actively working to restore service as quickly as possible.
Posted
Jul
27
,
2026
-
21:31
UTC
This incident affected: GoDaddy Support (Messaging Support Services).
×
Subscribe to Incident
Subscribe to updates for
Chat Support Degraded
via . You'll receive .